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Introduction to AutoCell 2.0
"Cellular automata are stylized, synthetic universes... They have their own kind of matter which whirls 
around in a space and a time of their own."
 - Tommanso Toffoli (quoted from an A.K. Dewdney article)
Cellular automata represent some of the most interesting and colorful mathematical phenomena. AutoCell
2.0 allows you to explore a virtually infinite number of cellular automaton universes beyond Conway's 
"Life." Using simple rules, and with drawing and editing tools, you can quickly construct a miniature 
universe or a cellular computer. States of cells in AutoCell 2.0 are defined as colors chosen from a 
palette.
You are encouraged to explore AutoCell 2.0 by reading the tutorial document and by examining various 
sample files.
AutoCell 2.0 is shareware, and may be registered for $20 U.S. ($24 Can.) payable to:

Paul Keet
12726 Southridge Dr.,
Surrey, B.C., Canada
V3X 3C6

Your shareware registration fee will help ensure a supply of quality products like the one you are now 
using.
Please feel free to send me any interesting discovers or offer any suggestions on improving AutoCell 2.0 
at the above address. You may also contact me through CompuServe at 70530,3622.



Creating a New Board
To create a new cellular automaton universe, select New menu item from the File menu and choose a 
playing board of the dimensions you desire. Please note, that for structural reasons, your board can't 
contain more than 61,440 cells (e.g. 320 cells wide by 192 cells high). AutoCell 2.0 will automatically 
enforce this limit.
After creating a board, you must add rules and initialize the playing board.
See also:

Importing Rules
Randomize
Tools



Exporting a Bitmap
You may export a bitmap for use in other programs by selecting Export Bitmap menu item from the File 
menu. You will be prompted for the name of the bitmap and a destination. Bitmaps are saved in 256 color 
device-independent bitmap (DIB) format.



Editing a Board
You may use any of the five drawing tools from the Toolbar to place cell of a color selected from the 
palette on the playing board. You may copy, cut, paste or clear a section of the playing board by selecting 

the capture  tool on the Toolbar and choosing the appropriate function under the Edit menu.
See also:

Tools



Grid
Select the Grid menu item from the Options menu to place a grid over the board. Grids will not show on 
windows set to the lowest magnification.



Airbrush
The airbrush allows you to randomly place cells of different colors. You can change the rate of flow of the 
airbrush by selecting the appropriate level in the Airbrush menu item under the Tools menu.
See also:

Tools



Using a Board
 Leave the title of the playing board, the author and text notes about the board.

 Access the Rulebook for a board.

 Rewind. This will return the playing board to the state it was in it first generation.

 Step. This will move the playing board forward one generation.

 Stop/Play. Start and stop a board.

 Fast Forward. Move as quickly as possible from generation to generation. Note: the fastest possible 
speed is less than ten frames per second.
See Also:

Creating a New Board
Editing a Board
Grid
Importing Rules
Notes
Tools



Rulebook
After selecting which color of cells you wish to view the rule for from the palette at the top right hand 
corner of the Rulebook dialog box, you may perform one of the following functions.

 Choose the default color. If no rules apply to the current cell from the Rulebook, the cell will 
automatically turn this color.

 Add a rule to the Rulebook. This will create a rule after the currently selected rule and call up the 
Rule Editor dialog box.

 Edit a rule. This will call up the Rule Editor dialog box and allow you to edit the currently selected 
rule. You may also double-click on the rule in the list to call up the Rule Editor.

 Delete a rule. This will remove the currently selected rule from the rule list.

 Move a rule up. This will change the order of the rule list by moving a rule up in the list. Sometimes
the order that rules are placed in will matter.

 Move a rule down.

In addition, you may also set the neighborhood that the rules will apply within by selecting a neighborhood

of eight  or a neighborhood of four 

 cells.
See also:

Importing Rules



Rule Editor
The first color box on the Rule Editor dialog represents the initial state of a given cell. The second color 
box represents the state the cell will become if the rule is met. This color may be changed to the color 
selected on the palette by clicking on the up arrow beneath it.
The remainder of the rule is initially blank, but can be created by clicking on the second up arrow. Clicking
on the up arrow will generate a string of color boxes with numbers. The first time a color is chosen, that 
color will appear with the number 0. The second time it is chosen, the number associated with the color 
will change to a 1, and so on. The colors and numbers thus chosen represents a pattern that must be 
matched for the rule to apply.
You may clear the rule if you wish to change it by selecting the Clear button. If you wish to leave the Rule 
Editor dialog without changing the rule, select Cancel.
See also:

Importing Rules
Rulebook
Rules



Notes
By choosing  on the ribbon above a playing board, you may input a title of the board, your name and 
a description of the board. You are encouraged to keep copious notes about your projects, and to send 
interesting projects to the author of AutoCell 2.0 at the address enclosed in the Introduction.



Rules
A rule for a cellular automaton looks like this:

The above rule is interpreted as "a white cell becomes black if it is touching three black cells." This rule is,
incidentally, one of the rules used in Conway's Life.
A rule with a 0 in it, like:

is interpreted at "a red cell becomes black if it is touching two yellow cells and no (zero) green cells.
If none of the rules are applied, a cell becomes the default color. The default color is determined for each 
cell color in the Rulebook.
Rules are stored in a Rulebook for a playing board. The order rules appear in determine the order the 
rules are applied in. If a rule is successful none of the rules that follow will be applied for that cell; the 
order that rules appear in can therefore sometimes be important.
These rules form the heart of AutoCell 2.0, and are constructed in such a way as to be quickly interpreted 
by the program. A virtually unlimited number of cellular automatons can be constructed using these rules. 
I recommend that you examine some of the sample AutoCell 2.0 files included; pay close attention to their
rules.
See also:

Importing Rules
Rule Editor



Import Rules
You may import rules from a saved AutoCell 2.0 (*.brd) file. It is not necessary to rewrite all the rules when
you create a new playing board, you may simply borrow them from another playing board. Note that 
existing rules for a playing board are lost when rules are imported.
See also:

Rules



Default
The default color is the color a cell will turn if no rules are applied. You may change the default color by 
clicking on the 'Default' button in the Rulebook.
See also:

Rules



Palettes
The floating palette is used to select colors for drawing. Double clicking on a palette entry will allow you to
change the Red-Green-Blue composition of that color. The palette may be shown or hidden by selecting 
the Show Palette menu item. Palettes may also be stored or saved.
Please note that AutoCell 2.0 is designed to work with a 256 color palette, I recommend switching video 
modes to 256 color mode or better to enjoy AutoCell 2.0. It should, however, work in virtually any color 
mode except CGA.
See also:

Randomize
Tools



Randomize
You can randomize a playing board by selecting the Randomize menu item under the Edit menu. Each 
cell on the playing board will be changed to a random color. Only colors for which rules apply will be used.
See also:

Palette



Tools
The following tools are available on the floating Toolbar:

 Turn a cell into a specified color.

 Capture a group of cells for editing.

 Draw a line of color.

 Airbrush color onto the playing board.

 Draw an empty rectangle of color.

 Draw a filled rectangle of color.

 Zoom in onto a location on the board. You may zoom in to a maximum of 32 pixels per cell.

 Zoom out from the board. Note that clicking this button will not change the tool selected.
The Toolbar can be shown or hidden by selecting the Show Toolbar menu item under the Options menu.



Life
"Life" refers to a type of cellular automaton discovered by John Conway, a mathematician at the 
University of Cambridge, in the sixties. Life is based upon the following rules:

a) Cells may be either black or white;
b) A black cell will remain black if it is touching two or three other black cells, otherwise it will turn 

white;
c) A white cell will remain white unless it is touching three black cells, in which case it will become 

black.
These simple rules lead to complex behaviors. Life is the most popular cellular automaton; much has 
been written about it in books and the Mathematical Recreations column in the Scientific American. Life 
is, however, only one type of a large variety of cellular automata.



Cellular Automata
Cellular automata are collections of cells whose individual state is determined by its previous state and 
the state of the cells surrounding it. States in AutoCell 2.0 are represented as colors. Some rules lead to 
self-replicating patterns, e.g. 'gliders' in Conway's Life, while other rules can yield patterns which exhibit 
complex and even cooperative behavior.
Cellular automata are divided into four categories:

Class I Automata form into fixed, homogeneous patterns;
Class II Automata form simple oscillating patterns;
Class III Automata become unpredictable, although tending towards certain patterns;
Class IV Automata form complex, regional patterns.

Class IV cellular automata, Conway's "Life" as an example, are the most interesting type and also the 
hardest to classify.



Tutorial
The purpose of this tutorial is to give you a brief introduction to AutoCell 2.0 by constructing the board and
the rules for Conway's "Life," a popular type of cellular automaton. To refresh your memory, Life is played 
on a black and white playing board with the following rules:

a) a black cell will be "born" when a white cell is touching three black cells:

b) a black cell will die unless it is touching two or three other black cells:

To make the best use of this tutorial print it out and place it beside you. Follow the instructions step by 
step.

1. Open AutoCell 2.0.

2. Select "New" from the "File" menu.

3. Use scroll bars to set the desired playing board size.

4. Click on 'Okay.'

5. Click on the Rulebook button:  You will now be in the Rulebook dialog.

6. Note that the default color setting for black will be white, that is to say a black cell will turn white 
unless a rule determines otherwise. If the default is not white, change it to white.

7. Click on the Add Rule button:  You will now be in the Rule Editor.
8. Ensure that you have black selected in the color palette.

9. Click on the first arrow:  The white colored box above the first arrow should go black.

10. Click on the second arrow three times. Your rule should look like this:

If it does not, click the "Clear" rule button and repeat from step 8. This rule should be interpreted as "a 
black cell will turn black if touching two other black cells."
11. Click on the "Okay" button.
12. Click on the Add Rule button again and make a rule that looks like this:

13. Click on the "Okay" button and go back to the Rulebook.

14. Select white from the palette at the top right-hand corner of the Rulebook.
You should now have no rules in your rule list. Also ensure that the default color is set to white.

15. Click on the Add Rule button and construct a rule that looks like this:

This rule should be interpreted as "a white cell will turn black if touching three black cells."

16. Click on the "Okay" button and go back to the Rulebook.
17. Click on the "Exit" button and return to AutoCell 2.0.

18. Either select "Randomize" from the edit menu, or use drawing tools to place black cells on the 
white board.



19. Click on the Stop/Play button: 

Conway's "Life" should erupt throughout your miniature universe. If it does not, backtrack through this 
tutorial and your steps to find out what you did wrong.




